Canada
HSDPA
LTE

Eastlink APN settings for HTC One M9s

      Eastlink   HTC One M9s   Android

HTC One M9s does not support Eastlink GSM / HSPA / LTE at this time.

Explain HTC One M9s compatibility with Eastlink

HTC One M9s has modal variants EMEA.

Eastlink 3G APN with HTC One M9s

HTC One M9s does not support Eastlink 3G.

Eastlink 4G LTE APN with HTC One M9s

EMEA

HTC One M9s EMEA does not support Eastlink 4G LTE.

Sorry, but it does not look like HTC One M9s will work on Eastlink. But please note that the compatibility of HTC One M9s with Eastlink, or the Eastlink network support on HTC One M9s we have explained here is only a technical specification match between HTC One M9s and Eastlink network. Even HTC One M9s is listed as not compatible here, still Eastlink network can allow (rarely) HTC One M9s in their network with special agreements made between Eastlink and HTC. Therefore, this only explains if the commonly available versions of HTC One M9s will work properly on Eastlink or not, if so in which bands HTC One M9s will work on Eastlink and the network performance between Eastlink and HTC One M9s. To check if HTC One M9s is really allowed in Eastlink network please contact Eastlink support. Do not use this website to decide to buy HTC One M9s to use on Eastlink.

HTC One M9s network specifications

OS Android OS, v5.1 (Lollipop)
Network bands GSM / HSPA / LTE
Speed HSPA, LTE
Network frequencies GSM 850 / 900 / 1800 / 1900
HSDPA 850 / 900 / 1900 / 2100
LTE band 1(2100), 3(1800), 5(850), 7(2600), 8(900), 20(800), 28(700), 38(2600), 40(2300), 41(2500) - EMEA
See full specs at GSM.COOL... Select a different device... Select a different network...
HTC One M9+ Eastlink APN settings
Not compatible
HTC One M9 Eastlink APN settings
67% compatible with Eastlink
LTE
HTC One ME Eastlink APN settings
Not compatible
HTC One M8s Eastlink APN settings
Not compatible
HTC One A9s Eastlink APN settings
67% compatible with Eastlink
LTE
HTC One E9+ Eastlink APN settings
Not compatible
HTC One X10 Eastlink APN settings
Not compatible